#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(BEGIN @\d+)\b(?s:.*?)(ACTION_READLN.*)"
Local $sString = "BEGIN @1011 Text" & @CRLF & _
"Text" & @CRLF & _
" ACTION_READLN ~corantimer~" & @CRLF & _
"Text" & @CRLF & _
"END" & @CRLF & _
"BEGIN @1012" & @CRLF & _
"asdasd" & @CRLF & _
" ACTION_READLN ~corantimer~" & @CRLF & _
"END" & @CRLF & _
"BEGIN @1013" & @CRLF & _
"" & @CRLF & _
"asd" & @CRLF & _
"END"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")