import Foundation
let pattern = #"(BEGIN @\d+)\b(?s:.*?)(ACTION_READLN.*)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
BEGIN @1011 Text
Text
ACTION_READLN ~corantimer~
Text
END
BEGIN @1012
asdasd
ACTION_READLN ~corantimer~
END
BEGIN @1013
asd
END
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)