const regex = /(BEGIN @\d+)\b(?s:.*?)(ACTION_READLN.*)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(BEGIN @\\d+)\\b(?s:.*?)(ACTION_READLN.*)', 'g')
const str = `BEGIN @1011 Text
Text
ACTION_READLN ~corantimer~
Text
END
BEGIN @1012
asdasd
ACTION_READLN ~corantimer~
END
BEGIN @1013
asd
END`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}