$re = '/(BEGIN @\d+)\b(?s:.*?)(ACTION_READLN.*)/';
$str = 'BEGIN @1011 Text
Text
ACTION_READLN ~corantimer~
Text
END
BEGIN @1012
asdasd
ACTION_READLN ~corantimer~
END
BEGIN @1013
asd
END';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);