import re
regex = re.compile(r"(BEGIN @\d+)\b(?s:.*?)(ACTION_READLN.*)")
test_str = ("BEGIN @1011 Text\n"
"Text\n"
" ACTION_READLN ~corantimer~\n"
"Text\n"
"END\n"
"BEGIN @1012\n"
"asdasd\n"
" ACTION_READLN ~corantimer~\n"
"END\n"
"BEGIN @1013\n\n"
"asd\n"
"END")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")