import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(BEGIN @\\d+)\\b(?s:.*?)(ACTION_READLN.*)";
final String string = "BEGIN @1011 Text\n"
+ "Text\n"
+ " ACTION_READLN ~corantimer~\n"
+ "Text\n"
+ "END\n"
+ "BEGIN @1012\n"
+ "asdasd\n"
+ " ACTION_READLN ~corantimer~\n"
+ "END\n"
+ "BEGIN @1013\n\n"
+ "asd\n"
+ "END";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}