package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(BEGIN @\d+)\b(?s:.*?)(ACTION_READLN.*)`)
var str = `BEGIN @1011 Text
Text
ACTION_READLN ~corantimer~
Text
END
BEGIN @1012
asdasd
ACTION_READLN ~corantimer~
END
BEGIN @1013
asd
END`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}