using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(BEGIN @\d+)\b(?s:.*?)(ACTION_READLN.*)";
string input = @"BEGIN @1011 Text
Text
ACTION_READLN ~corantimer~
Text
END
BEGIN @1012
asdasd
ACTION_READLN ~corantimer~
END
BEGIN @1013
asd
END";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}