package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)<div\s\w{5}=\"print[^>]*?>[\s\S]*?<\/div>`)
var str = `<div class="print">
<a href="javascript:window.print();" title="Print denne side"><span class="print-btn icon">P</span> Print denne side</a>
</div>
<div source="">
<div>`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}