import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<div\\s\\w{5}=\\\"print[^>]*?>[\\s\\S]*?<\\/div>";
final String string = "<div class=\"print\">\n"
+ " <a href=\"javascript:window.print();\" title=\"Print denne side\"><span class=\"print-btn icon\">P</span> Print denne side</a>\n"
+ " </div>\n"
+ "<div source=\"\">\n"
+ "<div>";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}