// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?i)<div\s\w{5}=\"print[^>]*?>[\s\S]*?<\/div>"#).unwrap();
let string = "<div class=\"print\">
<a href=\"javascript:window.print();\" title=\"Print denne side\"><span class=\"print-btn icon\">P</span> Print denne side</a>
</div>
<div source=\"\">
<div>";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}