import Foundation
let pattern = #"<div\s\w{5}=\"print[^>]*?>[\s\S]*?<\/div>"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"""
<div class="print">
<a href="javascript:window.print();" title="Print denne side"><span class="print-btn icon">P</span> Print denne side</a>
</div>
<div source="">
<div>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)