#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?:\n|^)(?:[^'"])*?(?:'(?:[^\\\r\n]|[\\]{2}|\\')*'|"(?:[^\\\r\n]|[\\]{2}|\\")*")*?(?:[^'"])*?(\/\*(?:[\s\S]*?)\*\/)"
Local $sString = "/* block 1 multi" & @CRLF & _
"*/" & @CRLF & _
"var b = function(){ /* block 2 contained */ };" & @CRLF & _
"" & @CRLF & _
""/* invalid block */";" & @CRLF & _
"" & @CRLF & _
""\" /* invalid block tricky */";" & @CRLF & _
"" & @CRLF & _
""\\ \\\""; /* valid block tricky */" & @CRLF & _
"" & @CRLF & _
"// Ignore Case: note - collapse regex first, then block comments" & @CRLF & _
"var trickiest = /\/* invalid block trickiest */gmi;" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")