// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?:\n|^)(?:[^'"])*?(?:'(?:[^\\\r\n]|[\\]{2}|\\')*'|"(?:[^\\\r\n]|[\\]{2}|\\")*")*?(?:[^'"])*?(\/\*(?:[\s\S]*?)\*\/)"#).unwrap();
let string = "/* block 1 multi
*/
var b = function(){ /* block 2 contained */ };
\"/* invalid block */\";
\"\\\" /* invalid block tricky */\";
\"\\\\ \\\\\\\"\"; /* valid block tricky */
// Ignore Case: note - collapse regex first, then block comments
var trickiest = /\\/* invalid block trickiest */gmi;
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}