import Foundation
let pattern = #"(?:\n|^)(?:[^'"])*?(?:'(?:[^\\\r\n]|[\\]{2}|\\')*'|"(?:[^\\\r\n]|[\\]{2}|\\")*")*?(?:[^'"])*?(\/\*(?:[\s\S]*?)\*\/)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
/* block 1 multi
*/
var b = function(){ /* block 2 contained */ };
"/* invalid block */";
"\" /* invalid block tricky */";
"\\ \\\""; /* valid block tricky */
// Ignore Case: note - collapse regex first, then block comments
var trickiest = /\/* invalid block trickiest */gmi;
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)