$re = '/(?:\n|^)(?:[^\'"])*?(?:\'(?:[^\\\\\r\n]|[\\\\]{2}|\\\\\')*\'|"(?:[^\\\\\r\n]|[\\\\]{2}|\\\\")*")*?(?:[^\'"])*?(\/\*(?:[\s\S]*?)\*\/)/';
$str = '/* block 1 multi
*/
var b = function(){ /* block 2 contained */ };
"/* invalid block */";
"\\" /* invalid block tricky */";
"\\\\ \\\\\\""; /* valid block tricky */
// Ignore Case: note - collapse regex first, then block comments
var trickiest = /\\/* invalid block trickiest */gmi;
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);