import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:\\n|^)(?:[^'\"])*?(?:'(?:[^\\\\\\r\\n]|[\\\\]{2}|\\\\')*'|\"(?:[^\\\\\\r\\n]|[\\\\]{2}|\\\\\")*\")*?(?:[^'\"])*?(\\/\\*(?:[\\s\\S]*?)\\*\\/)";
final String string = "/* block 1 multi\n"
+ "*/\n"
+ "var b = function(){ /* block 2 contained */ };\n\n"
+ "\"/* invalid block */\";\n\n"
+ "\"\\\" /* invalid block tricky */\";\n\n"
+ "\"\\\\ \\\\\\\"\"; /* valid block tricky */\n\n"
+ "// Ignore Case: note - collapse regex first, then block comments\n"
+ "var trickiest = /\\/* invalid block trickiest */gmi;\n\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}