use strict;
my $str = '/* block 1 multi
*/
var b = function(){ /* block 2 contained */ };
"/* invalid block */";
"\\" /* invalid block tricky */";
"\\\\ \\\\\\""; /* valid block tricky */
// Ignore Case: note - collapse regex first, then block comments
var trickiest = /\\/* invalid block trickiest */gmi;
';
my $regex = qr/(?:\n|^)(?:[^'"])*?(?:'(?:[^\\\r\n]|[\\]{2}|\\')*'|"(?:[^\\\r\n]|[\\]{2}|\\")*")*?(?:[^'"])*?(\/\*(?:[\s\S]*?)\*\/)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}