using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:\n|^)(?:[^'""])*?(?:'(?:[^\\\r\n]|[\\]{2}|\\')*'|""(?:[^\\\r\n]|[\\]{2}|\\"")*"")*?(?:[^'""])*?(\/\*(?:[\s\S]*?)\*\/)";
string input = @"/* block 1 multi
*/
var b = function(){ /* block 2 contained */ };
""/* invalid block */"";
""\"" /* invalid block tricky */"";
""\\ \\\""; /* valid block tricky */
// Ignore Case: note - collapse regex first, then block comments
var trickiest = /\/* invalid block trickiest */gmi;
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}