# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?:\n|^)(?:[^'\"])*?(?:'(?:[^\\\r\n]|[\\]{2}|\\')*'|\"(?:[^\\\r\n]|[\\]{2}|\\\")*\")*?(?:[^'\"])*?(\/\*(?:[\s\S]*?)\*\/)"
test_str = ("/* block 1 multi\n"
"*/\n"
"var b = function(){ /* block 2 contained */ };\n\n"
"\"/* invalid block */\";\n\n"
"\"\\\" /* invalid block tricky */\";\n\n"
"\"\\\\ \\\\\\\"\"; /* valid block tricky */\n\n"
"// Ignore Case: note - collapse regex first, then block comments\n"
"var trickiest = /\\/* invalid block trickiest */gmi;\n\n")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.