re = /(?:\n|^)(?:[^'"])*?(?:'(?:[^\\\r\n]|[\\]{2}|\\')*'|"(?:[^\\\r\n]|[\\]{2}|\\")*")*?(?:[^'"])*?(\/\*(?:[\s\S]*?)\*\/)/
str = '/* block 1 multi
*/
var b = function(){ /* block 2 contained */ };
"/* invalid block */";
"\\" /* invalid block tricky */";
"\\\\ \\\\\\""; /* valid block tricky */
// Ignore Case: note - collapse regex first, then block comments
var trickiest = /\\/* invalid block trickiest */gmi;
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end