const regex = /(?:\n|^)(?:[^'"])*?(?:'(?:[^\\\r\n]|[\\]{2}|\\')*'|"(?:[^\\\r\n]|[\\]{2}|\\")*")*?(?:[^'"])*?(\/\*(?:[\s\S]*?)\*\/)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:\\n|^)(?:[^\'"])*?(?:\'(?:[^\\\\\\r\\n]|[\\\\]{2}|\\\\\')*\'|"(?:[^\\\\\\r\\n]|[\\\\]{2}|\\\\")*")*?(?:[^\'"])*?(\\\/\\*(?:[\\s\\S]*?)\\*\\\/)', 'g')
const str = `/* block 1 multi
*/
var b = function(){ /* block 2 contained */ };
"/* invalid block */";
"\\" /* invalid block tricky */";
"\\\\ \\\\\\""; /* valid block tricky */
// Ignore Case: note - collapse regex first, then block comments
var trickiest = /\\/* invalid block trickiest */gmi;
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}