# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(http:\\/\\/cfile([0-9]+)(.)([a-z]+)(.)tistory.com\\/original\\/([a-zA-z0-9]+))(?![\s\S]*\1)//g;t' <<< "http://cfile21.uf.tistory.com/original/212BA64E563633880B731B
http://cfile21.uf.tistory.com/original/212BA64E563633880B731B
http://cfile21.uf.tistory.com/original/212BA64E563633880B731B"