import Foundation
let pattern = #"(http:\/\/cfile([0-9]+)(.)([a-z]+)(.)tistory.com\/original\/([a-zA-z0-9]+))(?![\s\S]*\1)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
http://cfile21.uf.tistory.com/original/212BA64E563633880B731B
http://cfile21.uf.tistory.com/original/212BA64E563633880B731B
http://cfile21.uf.tistory.com/original/212BA64E563633880B731B
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)