using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(http:\/\/cfile([0-9]+)(.)([a-z]+)(.)tistory.com\/original\/([a-zA-z0-9]+))(?![\s\S]*\1)";
string substitution = @"";
string input = @"http://cfile21.uf.tistory.com/original/212BA64E563633880B731B
http://cfile21.uf.tistory.com/original/212BA64E563633880B731B
http://cfile21.uf.tistory.com/original/212BA64E563633880B731B";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}