import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(http:\\/\\/cfile([0-9]+)(.)([a-z]+)(.)tistory.com\\/original\\/([a-zA-z0-9]+))(?![\\s\\S]*\\1)";
final String string = "http://cfile21.uf.tistory.com/original/212BA64E563633880B731B\n"
+ "http://cfile21.uf.tistory.com/original/212BA64E563633880B731B\n"
+ "http://cfile21.uf.tistory.com/original/212BA64E563633880B731B";
final String subst = "";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}