# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(http:\/\/cfile([0-9]+)(.)([a-z]+)(.)tistory.com\/original\/([a-zA-z0-9]+))(?![\s\S]*\1)"
test_str = ("http://cfile21.uf.tistory.com/original/212BA64E563633880B731B\n"
"http://cfile21.uf.tistory.com/original/212BA64E563633880B731B\n"
"http://cfile21.uf.tistory.com/original/212BA64E563633880B731B")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.