re = /(http:\/\/cfile([0-9]+)(.)([a-z]+)(.)tistory.com\/original\/([a-zA-z0-9]+))(?![\s\S]*\1)/
str = 'http://cfile21.uf.tistory.com/original/212BA64E563633880B731B
http://cfile21.uf.tistory.com/original/212BA64E563633880B731B
http://cfile21.uf.tistory.com/original/212BA64E563633880B731B'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result