const regex = /(http:\/\/cfile([0-9]+)(.)([a-z]+)(.)tistory.com\/original\/([a-zA-z0-9]+))(?![\s\S]*\1)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(http:\\\/\\\/cfile([0-9]+)(.)([a-z]+)(.)tistory.com\\\/original\\\/([a-zA-z0-9]+))(?![\\s\\S]*\\1)', 'g')
const str = `http://cfile21.uf.tistory.com/original/212BA64E563633880B731B
http://cfile21.uf.tistory.com/original/212BA64E563633880B731B
http://cfile21.uf.tistory.com/original/212BA64E563633880B731B`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);