# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(<UTop>[^<]+)/\1<\/UTop>/g;t' <<< "<Top>1. Regierungserklärung des Ministerpräsidenten<UTop>Ministerpräsident Winfried Kretschmann
</Top>"