use strict;
my $str = '<Top>1. Regierungserklärung des Ministerpräsidenten<UTop>Ministerpräsident Winfried Kretschmann
</Top>';
my $regex = qr/(<UTop>[^<]+)/p;
my $subst = '\\1</UTop>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";