$re = '/(<UTop>[^<]+)/';
$str = '<Top>1. Regierungserklärung des Ministerpräsidenten<UTop>Ministerpräsident Winfried Kretschmann
</Top>';
$subst = "\1</UTop>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;