// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(<UTop>[^<]+)").unwrap();
let string = "<Top>1. Regierungserklärung des Ministerpräsidenten<UTop>Ministerpräsident Winfried Kretschmann
</Top>";
let substitution = "\\1</UTop>";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}