re = /(<UTop>[^<]+)/
str = '<Top>1. Regierungserklärung des Ministerpräsidenten<UTop>Ministerpräsident Winfried Kretschmann
</Top>'
subst = '\\1</UTop>'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result