package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(<UTop>[^<]+)`)
var str = `<Top>1. Regierungserklärung des Ministerpräsidenten<UTop>Ministerpräsident Winfried Kretschmann
</Top>`
var substitution = "\1</UTop>"
fmt.Println(re.ReplaceAllString(str, substitution))
}