# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(<[ZY]{4}>\s(.*))/$0 --> $2 $1/g;t' <<< "<ZZZZ> Av
<asdd> 122
<xcxzc> a
<asas> es&
<wewa> n
<zasd> cu
<YYYY> asd"