using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(<[ZY]{4}>\s(.*))";
string substitution = @"$0 --> $2 $1";
string input = @"<ZZZZ> Av
<asdd> 122
<xcxzc> a
<asas> es&
<wewa> n
<zasd> cu
<YYYY> asd";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}