re = /(<[ZY]{4}>\s(.*))/
str = '<ZZZZ> Av
<asdd> 122
<xcxzc> a
<asas> es&
<wewa> n
<zasd> cu
<YYYY> asd'
subst = '$0 --> $2 $1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result