$re = '/(<[ZY]{4}>\s(.*))/';
$str = '<ZZZZ> Av
<asdd> 122
<xcxzc> a
<asas> es&
<wewa> n
<zasd> cu
<YYYY> asd';
$subst = "$0 --> $2 $1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;