use strict;
my $str = '<ZZZZ> Av
<asdd> 122
<xcxzc> a
<asas> es&
<wewa> n
<zasd> cu
<YYYY> asd';
my $regex = qr/(<[ZY]{4}>\s(.*))/p;
my $subst = '$0 --> $2 $1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";