const regex = /(<[ZY]{4}>\s(.*))/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(<[ZY]{4}>\\s(.*))', 'g')
const str = `<ZZZZ> Av
<asdd> 122
<xcxzc> a
<asas> es&
<wewa> n
<zasd> cu
<YYYY> asd`;
const subst = `$0 --> $2 $1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);