#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(<[ZY]{4}>\s(.*))"
Local $sString = "<ZZZZ> Av" & @CRLF & _
"<asdd> 122" & @CRLF & _
"<xcxzc> a" & @CRLF & _
"<asas> es&" & @CRLF & _
"<wewa> n" & @CRLF & _
"<zasd> cu" & @CRLF & _
"" & @CRLF & _
"<YYYY> asd"
Local $sSubst = "$0 --> $2 $1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)