# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(<[ZY]{4}>\s(.*))"
test_str = ("<ZZZZ> Av\n"
"<asdd> 122\n"
"<xcxzc> a\n"
"<asas> es&\n"
"<wewa> n\n"
"<zasd> cu\n\n"
"<YYYY> asd")
subst = "$0 --> $2 $1"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.