import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(<[ZY]{4}>\\s(.*))";
final String string = "<ZZZZ> Av\n"
+ "<asdd> 122\n"
+ "<xcxzc> a\n"
+ "<asas> es&\n"
+ "<wewa> n\n"
+ "<zasd> cu\n\n"
+ "<YYYY> asd";
final String subst = "$0 --> $2 $1";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}