package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(<[ZY]{4}>\s(.*))`)
var str = `<ZZZZ> Av
<asdd> 122
<xcxzc> a
<asas> es&
<wewa> n
<zasd> cu
<YYYY> asd`
var substitution = "$0 --> $2 $1"
fmt.Println(re.ReplaceAllString(str, substitution))
}