# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/absoluteText_(\d+)\([^,]+,\s*(.*?)\)/absoluteText_$1($2)/gm;t' <<< "absoluteText_12(A, B, C)"