const regex = /absoluteText_(\d+)\([^,]+,\s*(.*?)\)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('absoluteText_(\\d+)\\([^,]+,\\s*(.*?)\\)', 'gm')
const str = `absoluteText_12(A, B, C)`;
const subst = `absoluteText_$1($2)`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);