#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)absoluteText_(\d+)\([^,]+,\s*(.*?)\)"
Local $sString = "absoluteText_12(A, B, C)"
Local $sSubst = "absoluteText_$1($2)"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)