// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)absoluteText_(\d+)\([^,]+,\s*(.*?)\)").unwrap();
let string = "absoluteText_12(A, B, C)";
let substitution = "absoluteText_$1($2)";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}