using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"absoluteText_(\d+)\([^,]+,\s*(.*?)\)";
string substitution = @"absoluteText_$1($2)";
string input = @"absoluteText_12(A, B, C)";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}